Skip to main content
← All vulnerabilities
CVE-2025-3019

Cross-site scripting vulnerabilities in KNIME Business Hub web pages

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.13.3, 1.12.4
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

KNIME Business Hub is affected by several cross-site scripting vulnerabilities in its web pages. If a user clicks on a malicious link or opens a malicious web page, arbitrary Java Script may be executed with this user's permissions. This can lead to information loss and/or modification of existing data. The issues are caused by a bug https://github.com/Baroshem/nuxt-security/issues/610 in the widely used nuxt-security module. There are no viable workarounds therefore we strongly recommend to update to one of the following versions of KNIME Business Hub: • 1.13.3 or later • 1.12.4 or later

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • KNIME KNIME Business Hub

    From 1.13.0 · fixed in 1.13.3; From 1.12.0 · fixed in 1.12.4

References 1

knime.com