Skip to main content
← All vulnerabilities
CVE-2025-30177GHSA-VQ4P-PCHP-6G6V

Apache Camel: Camel-Undertow Message Header Injection via Improper Filtering

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.10.3, 4.8.6
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Bypass/Injection vulnerability in Apache Camel in Camel-Undertow component under particular conditions. This issue affects Apache Camel: from 4.10.0 before 4.10.3, from 4.8.0 before 4.8.6. Users are recommended to upgrade to version 4.10.3 for 4.10.x LTS and 4.8.6 for 4.8.x LTS. Camel undertow component is vulnerable to Camel message header injection, in particular the custom header filter strategy used by the component only filter the "out" direction, while it doesn't filter the "in" direction. This allows an attacker to include Camel specific headers that for some Camel components can alter the behaviour such as the camel-bean component, or the camel-exec component.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • org.apache.camel:camel-undertow

    From 4.10.0 · fixed in 4.10.3; From 4.8.0 · fixed in 4.8.6

  • org.apache.camel:camel-undertowMaven

    From 4.10.0 · fixed in 4.10.3

  • org.apache.camel:camel-undertowMaven

    From 4.8.0 · fixed in 4.8.6

References 3

camel.apache.org

lists.apache.org