Skip to main content
← All vulnerabilities
CVE-2025-30168GHSA-837Q-JHWX-CMPVBIT-PARSE-2025-30168

Parse Server has an OAuth login vulnerability

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 7.5.2, 8.0.2
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 7.5.2 and 8.0.2, the 3rd party authentication handling of Parse Server allows the authentication credentials of some specific authentication providers to be used across multiple Parse Server apps. For example, if a user signed up using the same authentication provider in two unrelated Parse Server apps, the credentials stored by one app can be used to authenticate the same user in the other app. Note that this only affects Parse Server apps that specifically use an affected 3rd party authentication provider for user authentication, for example by setting the Parse Server option auth to configure a Parse Server authentication adapter. The fix of this vulnerability requires to upgrade Parse Server to a version that includes the bug fix, as well as upgrade the client app to send a secure payload, which is different from the previous insecure payload. This vulnerability is fixed in 7.5.2 and 8.0.2.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • parse-community parse-server

    fixed in 7.5.2; From 8.0.0 · fixed in 8.0.2

  • parse-servernpm

    fixed in 7.5.2

  • parse-servernpm

    From 8.0.0 · fixed in 8.0.2

References 6

GitHub · parse-community/parse-server

docs.parseplatform.org