Authorization Bypass in Next.js Middleware
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 12.3.5, 14.2.25, 15.2.3, 13.5.9
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 1 on Exploit-DB, 1 Metasploit module, 127 proofs of concept on GitHub, 1 Nuclei template
- Exploitation: none
- Automatable: yes
- Technical impact: total
Summary
Next.js is a React framework for building full-stack web applications. Starting in version 1.11.4 and prior to versions 12.3.5, 13.5.9, 14.2.25, and 15.2.3, it is possible to bypass authorization checks within a Next.js application, if the authorization check occurs in middleware. If patching to a safe version is infeasible, it is recommend that you prevent external user requests which contain the x-middleware-subrequest header from reaching your Next.js application. This vulnerability is fixed in 12.3.5, 13.5.9, 14.2.25, and 15.2.3.
Timeline
- CVE published
- Public exploit on Exploit-DB
EDB-52124
- CISA SSVC assessment
Exploitation: none · Automatable: yes · Technical impact: total
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- vercel next.js
From 11.1.4 · fixed in 12.3.5; From 14.0.0 · fixed in 14.2.25; From 15.0.0 · fixed in 15.2.3; From 13.0.0 · fixed in 13.5.9
- nextnpm
From 13.0.0 · fixed in 13.5.9
- nextnpm
From 14.0.0 · fixed in 14.2.25
- nextnpm
From 15.0.0 · fixed in 15.2.3
- nextnpm
From 12.0.0 · fixed in 12.3.5