Skip to main content
← All vulnerabilities
CVE-2025-27802

Stored Cross-Site Scripting in Episerver Content Management System (CMS) Edit Preview

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 11.21.4, 12.22.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

The Episerver Content Management System (CMS) by Optimizely was affected by multiple Stored Cross-Site Scripting (XSS) vulnerabilities. This allowed an authenticated attacker to execute malicious JavaScript code in the victim's browser. RTE properties (text fields), which could be used in the "Edit" section of the CMS, allowed the input of arbitrary text. It was possible to input malicious JavaScript code in these properties that would be executed if a user visits the previewed page. Attackers needed at least the role "WebEditor" in order to exploit this issue. Affected products: Version 11.X: EPiServer.CMS.Core (<11.21.4) with EPiServer.CMS.UI (<11.37.5), Version 12.X: EPiServer.CMS.Core (<12.22.1) with EPiServer.CMS.UI (<11.37.3)

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Optimizely Episerver Content Management System (CMS)

    From 11.x · fixed in 11.21.4; From 12.x · fixed in 12.22.1

References 3

api.nuget.optimizely.com

r.sec-consult.com