Skip to main content
← All vulnerabilities
CVE-2025-26619GHSA-RCW3-WMX7-CPHR

Vega Cross-Site Scripting (XSS) via event filter when not using CSP mode `expressionInterpeter`

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 5.31.0, 5.16.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: yes
  • Technical impact: partial

Summary

Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. In `vega` 5.30.0 and lower and in `vega-functions` 5.15.0 and lower , it was possible to call JavaScript functions from the Vega expression language that were not meant to be supported. The issue is patched in `vega` `5.31.0` and `vega-functions` `5.16.0`. Some workarounds are available. Run `vega` without `vega.expressionInterpreter`. This mode is not the default as it is slower. Alternatively, using the interpreter described in CSP safe mode (Content Security Policy) prevents arbitrary Javascript from running, so users of this mode are not affected by this vulnerability.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • vega vega

    fixed in 5.31.0

  • veganpm

    fixed in 5.31.0

  • vega-functionsnpm

    fixed in 5.16.0

References 4

GitHub · vega/vega

GitHub · vega/vega-lite