Skip to main content
← All vulnerabilities
CVE-2025-25299GHSA-J3MM-WMFM-MWVH

Cross-site scripting (XSS) in the real-time collaboration package

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 44.2.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. During a recent internal audit, a Cross-Site Scripting (XSS) vulnerability was discovered in the CKEditor 5 real-time collaboration package. This vulnerability affects user markers, which represent users' positions within the document. It can lead to unauthorized JavaScript code execution, which might happen with a very specific editor and token endpoint configuration. This vulnerability affects only installations with Real-time collaborative editing enabled. The problem has been recognized and patched. The fix is available in version 44.2.1 (and above). Users are advised to upgrade. There are no known workarounds for this vulnerability.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • ckeditor ckeditor5

    Version range not reported

  • @ckeditor/ckeditor5-real-time-collaborationnpm

    From 41.3.0 · fixed in 44.2.1

  • ckeditor5-premium-featuresnpm

    From 42.0.0 · fixed in 44.2.1

References 3

GitHub · ckeditor/ckeditor5

ckeditor.com