Skip to main content
← All vulnerabilities
CVE-2025-25288GHSA-H5C3-5R3R-RR8Q

@octokit/plugin-paginate-rest has a Regular Expression in iterator that Leads to ReDoS Vulnerability Due to Catastrophic Backtracking

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 11.4.1, 9.2.2
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: yes
  • Technical impact: partial

Summary

@octokit/plugin-paginate-rest is the Octokit plugin to paginate REST API endpoint responses. For versions starting in 1.0.0 and prior to 11.4.1 of the npm package `@octokit/plugin-paginate-rest`, when calling `octokit.paginate.iterator()`, a specially crafted `octokit` instance—particularly with a malicious `link` parameter in the `headers` section of the `request`—can trigger a ReDoS attack. Version 11.4.1 contains a fix for the issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • octokit plugin-paginate-rest.js

    From 1.0.0 · fixed in 11.4.1

  • @octokit/plugin-paginate-restnpm

    From 9.3.0-beta.1 · fixed in 11.4.1

  • @octokit/plugin-paginate-restnpm

    From 1.0.0 · fixed in 9.2.2

References 3

GitHub · octokit/plugin-paginate-rest.js