Skip to main content
← All vulnerabilities
CVE-2025-2527GO-2025-3691GHSA-H356-3MFW-X368

Improper access control to group information

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 9.11.12+incompatible, 10.5.3+incompatible, 8.0.0-20250411064244-844447fbd57c, 10.5.3, 9.11.12
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Mattermost versions 10.5.x <= 10.5.2, 9.11.x <= 9.11.11 failed to properly verify a user's permissions when accessing groups, which allows an attacker to view group information via an API request.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Mattermost Mattermost

    From 10.5.0 · through 10.5.2; From 9.11.0 · through 9.11.11

  • github.com/mattermost/mattermost-serverGo

    From 9.11.0+incompatible · fixed in 9.11.12+incompatible; From 10.5.0+incompatible · fixed in 10.5.3+incompatible

  • github.com/mattermost/mattermost-server/v5Go

    All versions

  • github.com/mattermost/mattermost-server/v6Go

    All versions

  • github.com/mattermost/mattermost/server/v8Go

    fixed in 8.0.0-20250411064244-844447fbd57c

  • github.com/mattermost/mattermost/server/v8Go

    From 10.5.0 · fixed in 10.5.3

  • github.com/mattermost/mattermost/server/v8Go

    From 9.11.0 · fixed in 9.11.12

References 1

mattermost.com