Skip to main content
← All vulnerabilities
CVE-2025-25247GHSA-4C37-7M5H-C8M9

Apache Felix Webconsole: XSS in services console

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.9.10, 5.0.10
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Felix Webconsole. This issue affects Apache Felix Webconsole 4.x up to 4.9.8 and 5.x up to 5.0.8. Users are recommended to upgrade to version 4.9.10 or 5.0.10 or higher, which fixes the issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Apache Software Foundation Apache Felix Webconsole

    From Version 4.x · through 4.9.8; From Version 5.x · through 5.0.8

  • org.apache.felix:org.apache.felix.webconsoleMaven

    From 4.0.0 · fixed in 4.9.10

  • org.apache.felix:org.apache.felix.webconsoleMaven

    From 5.0.0 · fixed in 5.0.10

References 1

lists.apache.org