Skip to main content
← All vulnerabilities
CVE-2025-25068GHSA-72QV-J8VR-XVFVBIT-MATTERMOST-2025-25068GO-2025-3551

Bypassing MFA Enforcement on Plugin Endpoints

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 10.4.3, 10.3.4, 9.11.9, 10.5.1, 9.11.9+incompatible, and 3 more
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Mattermost versions 10.4.x <= 10.4.2, 10.3.x <= 10.3.3, 9.11.x <= 9.11.8, 10.5.x <= 10.5.0 fail to enforce MFA on plugin endpoints, which allows authenticated attackers to bypass MFA protections via API requests to plugin-specific routes.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • Mattermost Mattermost

    From 10.4.0 · through 10.4.2; From 10.3.0 · through 10.3.3; From 9.11.0 · through 9.11.8

  • github.com/mattermost/mattermost/server/v8Go

    From 10.4.0 · fixed in 10.4.3

  • github.com/mattermost/mattermost/server/v8Go

    From 10.3.0 · fixed in 10.3.4

  • github.com/mattermost/mattermost/server/v8Go

    From 9.11.0 · fixed in 9.11.9

  • github.com/mattermost/mattermost/server/v8Go

    From 10.5.0 · fixed in 10.5.1

  • github.com/mattermost/mattermost-serverGo

    From 9.11.0+incompatible · fixed in 9.11.9+incompatible; From 10.3.0+incompatible · fixed in 10.3.4+incompatible; From 10.4.0+incompatible · fixed in 10.4.3+incompatible; From 10.5.0+incompatible · fixed in 10.5.1+incompatible

  • github.com/mattermost/mattermost-server/v5Go

    All versions

  • github.com/mattermost/mattermost-server/v6Go

    All versions

  • github.com/mattermost/mattermost/server/v8Go

    All versions

References 1

mattermost.com