Skip to main content
← All vulnerabilities
CVE-2025-24970GHSA-4G8C-WM8X-JFHW

SslHandler doesn't correctly validate packets which can lead to native crash when using native SSLEngine

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.1.118.Final
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: yes
  • Technical impact: partial

Summary

Netty, an asynchronous, event-driven network application framework, has a vulnerability starting in version 4.1.91.Final and prior to version 4.1.118.Final. When a special crafted packet is received via SslHandler it doesn't correctly handle validation of such a packet in all cases which can lead to a native crash. Version 4.1.118.Final contains a patch. As workaround its possible to either disable the usage of the native SSLEngine or change the code manually.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • netty netty

    From 4.1.91.Final · through 4.1.117.Final

  • io.netty:netty-handlerMaven

    From 4.1.91.Final · fixed in 4.1.118.Final

References 2

GitHub · netty/netty