Skip to main content
← All vulnerabilities
CVE-2025-24928

libxml2 before 2.12.10 and 2.13.x before 2.13.6 has a stack-based buffer overflow in xmlSnprintfElements in valid.c.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.12.10, 2.13.6
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

libxml2 before 2.12.10 and 2.13.x before 2.13.6 has a stack-based buffer overflow in xmlSnprintfElements in valid.c. To exploit this, DTD validation must occur for an untrusted document or untrusted DTD. NOTE: this is similar to CVE-2017-9047.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • xmlsoft libxml2

    fixed in 2.12.10; From 2.13.0 · fixed in 2.13.6

References 2

gitlab.gnome.org

issues.oss-fuzz.com